Do I need Lightroom in order to work with PE?

Nathan Holritz -

Lightroom is not required for Color Correction customers, but we recommend Lightroom 5 or Lightroom CC and the Smart Previews workflow for the best experience.

If you prefer not to use Lightroom, we can always return JPG files instead.

Lightroom is not necessary for Retouching services.

We no longer support Apple's Aperture software. 

Have more questions? Submit a request

Comments

Powered by Zendesk